Welcome
To join our community, please login or register!

What Minecraft versions are supported on the server?
Started by Mr.Zomka

We support Minecraft: Java Edition 1.8 till 1.17.1 and Minecraft: Bedrock Edition 1.17 till 1.17.2.

Older versions are not going to be supported.

Java IGN: Mr_Zomka ~ Bedrock IGN: *MrZomkaPlays ~ Discord: Mr.Zomka#0001